Hu:Beginners Guide 1.3.3

From OpenStreetMap Wiki
(Redirected from HU:Beginners Guide 1.2.3)
Jump to: navigation, search
Más nyelveken — Beginners Guide 1.3.3
· Afrikaans · Alemannisch · aragonés · asturianu · Aymar aru · azərbaycanca · Bahasa Indonesia · Bahasa Melayu · bamanankan · Bân-lâm-gú · Basa Jawa · Basa Sunda · Baso Minangkabau · bosanski · brezhoneg · català · čeština · corsu · dansk · Deutsch · eesti · English · español · Esperanto · estremeñu · euskara · français · Frysk · Gaeilge · Gàidhlig · galego · Hausa · hrvatski · Igbo · interlingua · Interlingue · isiXhosa · isiZulu · íslenska · italiano · Kiswahili · Kreyòl ayisyen · kréyòl gwadloupéyen · kurdî · Latina · latviešu · Lëtzebuergesch · lietuvių · Limburgs · magyar · Malagasy · Malti · Nederlands · Nedersaksies · norsk · norsk nynorsk · occitan · Oromoo · oʻzbekcha/ўзбекча · Plattdüütsch · polski · português · română · shqip · slovenčina · slovenščina · Soomaaliga · suomi · svenska · Tagalog · Tiếng Việt · Türkçe · Türkmençe · Vahcuengh · vèneto · walon · Wolof · Yorùbá · Zazaki · isiZulu · српски / srpski · авар · Аҧсшәа · башҡортса · беларуская · български · қазақша · Кыргызча · македонски · монгол · русский · тоҷикӣ · українська · Ελληνικά · Հայերեն · ქართული · नेपाली · भोजपुरी · मराठी · संस्कृतम् · हिन्दी · অসমীয়া · বাংলা · ਪੰਜਾਬੀ · ગુજરાતી · ଓଡ଼ିଆ · தமிழ் · తెలుగు · ಕನ್ನಡ · മലയാളം · සිංහල · བོད་ཡིག · ไทย · မြန်မာဘာသာ · ລາວ · ភាសាខ្មែរ · ⵜⴰⵎⴰⵣⵉⵖⵜ · አማርኛ · 한국어 · 日本語 · 中文(简体)‎ · 中文(繁體)‎ · 吴语 · 粵語 · ייִדיש · עברית · اردو · العربية · پښتو · سنڌي · فارسی · ދިވެހިބަސް

JOSM

A JOSM egy Java-alapú térképszerkesztő.

  • Java letöltése
  • WebStart linkkel a program automatikusan letöltődik és elindul, így mindig a legfrissebb verziót használod: JOSM WebStart
  • Ha nem működne, itt találsz WebStart súgót
  • Ha inkább letöltenéd a gépedre az aktuális verziót: JOSM letöltése. Ilyenkor a program a josm-tested.jar fájlra kattintással indítható. Linuxon esetleg a következő parancs kiadása lehet szükséges: java -jar josm-tested.jar

A szerkesztőfelület

A program hagyományos GUI-s programokhoz hasonlóan eszköztárakkal és menükkel rendelkezik. A felső eszköztáron találod például a térkép letöltést vagy mentést, illetve ide elhelyezhetsz gombokat a gyakran használt funkciók eléréséhez. A bal oldali eszköztáron a rajzolási és szerkesztési ikonokat felül, alatta pedig az egyes eszközablakok ki-bekapcsolására szolgáló ikonokat találod.

Az eszközablakokat a JOSM jobb szélén és a JOSM ablakától függetlenül kis ablakokban találod. Ezekben a szerkesztést segítő eszközöket találod, mindent amit szükséges. Az eszközablakok a sarkukban lévő kis ikonokkal rögzíthetők a JOSM ablakához vagy csatolhatók le különálló ablakká.

A menükben számtalan összetett szerkesztési funkciót megtalálsz, ilyen például a vonalak kettévágása, összeillesztése vagy területek derékszögűre alakítása.

Az megjelenített ikonok, menük és funkciók attól is függenek, hogy melyik bővítményeket kapcsolod be.

Térkép letöltése JOSM-ba

A JOSM-ban való szerkesztéshez először le kell tölteni a szerkesztendő terület meglévő térképét és a feltöltött GPS nyomvonalakat:

  1. Kattints a Fájl -> Adatok letöltése menüre (vagy ikonjára)
  2. Így keresd meg azt a területet, amelyiket szerkeszteni szeretnéd:
    1. Egérgörgő: nagyítás és kicsinyítés
    2. Jobb egérgomb lenyomása és mozgatás: a térkép mozgatása
    3. Bal egérgomb lenyomása és mozgatás: a letöltendő terület kijelölése
  3. Az ablak tetején válaszd ki, hogy mit szeretnél letölteni:
    1. OpenStreetMap adatok: az OSM térképadatai. Ez mindenképpen kelleni fog, mert ezt fogod szerkeszteni.
    2. Nyers GPS adatok: GPS-ekből mindenki által feltöltött adatok. Pontosabb rajzoláshoz mindenképpen hasznos lesz.
  4. Kattints a Letöltés gombra
JOSM download.png

A JOSM sraffozottan jelöli a letöltött területen kívül eső területeket. A sraffozott területen soha ne szerkessz, mert már ott lehet amit be szeretnél rajzolni.

Ha szerkesztés közben újra megnyitod a letöltés ablakot, alapból a képernyőn látható területet jelöli ki, így könnyedén tovább haladhatsz a munkával. Ez semmilyen hatással nem lesz a már elvégzett módosításaidra, és az sem okoz neki gondot, hogy belelógnak már letöltött elemek a letöltésbe (nem lesz belőlük kettő).

Az adataid feltöltéséhez az felhasználónév és jelszó lesz szükséges, amelyiket az OpenStreetMap.org oldalon is használsz a bejelentkezéshez! Ezt a JOSM az első feltöltéskor fogja kérni. Biztonságosabb bejelentkezéshez használd az OAuth-ot (Szerkesztés -> Beállítások -> OSM szerverhez kapcsolódás beállításai (földgömb ikon)).


Műholdkép megjelenítése

A műholdkép megjelenítéséhez válaszd az Légifelvétel menü -> Bing Műholdkép menüpontot, de próbálj ki más elemeket is ebből a menüből.

A kép pozíciójának kalibráláshoz a rétegek listában kattints jobb gombbal az műholdkép rétegre, válaszd a Új eltolás menüt. Amíg az az ablak nyitva van, a kurzor gombokkal és az egérrel mozgatható a kép. A műholdképet olyan helyen igazítsd, ahol sok GPS nyomvonal van feltöltve (lásd köv. pont), vagy igazítsd a meglévő OSM rajzolathoz. De vigyázz, mert az igazítás már néhány utcányival arrébb is más lehet.

GPS nyomvonalak megjelenítése

Az OSM szerverre már feltöltött GPS nyomvonalaidat a többiekével együtt letöltheted a JOSM letöltés ablakában (lásd a köv. oldalon).

A saját GPS nyomvonalakat a File -> Megnyitás... menüben is megnyithatod (.gpx formátumban). Ennek az az előnye, hogy a pontosság információ (HDOP) is megmarad, és a pontosságtól függő méretű köröket rajzol a program a vonalad mentén. Érdemes a többi feltöltött nyomvonalat is letölteni, mert több GPS nyomvonal pontosabb eredményt ad.

Fontos különbségek más hasonló programokhoz képest

  • A réteg (layer) itt az egész térképet tartalmazza egyben. A további rétegek lehetnek például műholdkép rétegek, de egyes eszközök is egy-egy saját rétegre rajzolnak, mint például a „mérőeszköz” (measure tool) vagy az „ellenőrző” (validator).
  • Fájlba való mentés jó helyi biztonsági mentésnek amíg dolgozol, így könnyen mentheted sűrűn (véd pl áramszünet esetén). De legkésőbb amikor abbahagyod a munkát, mindenképp töltsd is fel az OSM-re is. Amikor később megint szerkesztesz, ne a helyi fájlokat használd, hanem töltsd le megint a területet!
  • Ne tölts le a szükségesnél nagyobb területet! Nagy fájlokkal lassan dolgozik a JOSM. Általában felesleges néhány háztömbnél nagyobb terület letöltése. Ha mégis kijutnál a letöltött területből a sraffozott üres részekre, bármikor hozzátölthetsz további részleteket!

További információk


Előző | Következő