Talk:JOSM/Archive 1

From OpenStreetMap Wiki
Jump to navigation Jump to search

This page is an archive. Do not edit the contents of this page. Direct any additional comments to the current talk page Talk:JOSM

Zooming without a scrollwheel

How do you zoom out on a laptop (without mouse or scrollwheel)? Ojw 14:28, 27 May 2006 (UTC)

I just use the zoom out to all tracks Erik Johansson 19:18, 27 May 2006 (UTC)
You can also use the "zoom bar" in newer versions.. Erik Johansson 14:59, 19 Jun 2006 (UTC)
Or press Ctrl-. (Period) and Ctrl-, to zoom. Use a decent version for this to work (latest-beta.jar) --Imi 21:21, 8 September 2006 (BST)

Cycle tagging question

How can I define a way for bikes or a normal way for cars? Can I see this with different colors? --waschbaer 15:50, 9 Jul 2006 (UTC)

Use tags (properties) to differentiate between types of ways. If you are unsure what to use, look at [Map_Features], [Labels], ask in the mailing list for some "annotation presets" to load or use your common sense (in that order ;-D ) --Imi 21:21, 8 September 2006 (BST)

Way IDs

Is it possible to see the ID of a way that you've selected in JOSM? Ojw 12:12, 19 Jun 2006 (UTC)

Just press the middle mouse button on the way and watch out for the 'id' tag. --GabrielEbner 14:30, 19 Jun 2006 (UTC)
Thanks, that works! Ojw 16:37, 19 Jun 2006 (UTC)

Cannot Read Time From Point x

--blk 14:08, 28 Jun 2006 (UTC) for all Linux and OS X users who know above error box in josm: filter your gpx tracks with this script and it will output a file JOSM can read. Is there somekind of regexp support for windows?

 sed -E "s/([0-9]{4})-([0-9]{2})-([0-9]{2})T(.{8})Z/\2\/\3\/\1 \4/" filename.gpx > filename_timefixed.gpx

Tested with a BU-303 and Garmin GPSMAP 60CSx (i alredy emailed Imi about this and I'm sure he'll fix it as soon as he'll have time, so don't start mass e-mailing him about this ;) ..if someone wants to do it first, he'll probably also take the patch)

Are there still problems with timestamps? --Imi 21:21, 8 September 2006 (BST)
Perhaps the simplest way to get sed (and lots of other Unix tools for Windows) is to install Cygwin. Teratornis 10:18, 1 Jul 2006 (UTC)


It is possible to view LandSat data in JOSM? Lordelph 10:38, 22 September 2006 (BST)

Yes, it is now. See the main JOSM article. Rw 15:27, 8 October 2006 (BST)
...or more specifically see JOSM/Plugins/WMSPlugin -- Harry Wood 12:28, 1 February 2008 (UTC)

JOSM Version for Plugins

The article should, at least for the time being, note the minimum version of JOSM for the use of plugins. They didn't work for me with version 140 but did with 166. Also, it's worth noting that the plugins need to be enabled in the preferences dialog - or was that just for the plugins I downloaded before installing JOSM version 166? EdD 19:43, 28 October 2006 (BST)

Since that comment was made (over a year ago) JOSM has gone through many many releases, including new plugin manager features. Version issues are still a potential problem with any plugin, but I guess version problems across all plugins in general, are not happening any more. Specific versioning problems may be documented on the individual plugin pages. -- Harry Wood 12:28, 1 February 2008 (UTC)

How does JOSM work?

I am finding it impossible to manipulate the data I save and upload using JOSM. The manual is not comprehensive or simple enough. The whole concept of JOSM assumes knowledge of users which I do not have. I am not a computer novice but JOSM is like nothing I have ever seen before. Please could the wiki be used by all JOSM users to produce a basic manual which I can understand. So far I have spent hours trying to make it work and it is a bit demoralising.

Can I suggest that you join the IRC session: Mapping Techniques, Tips and Tricks. The next one is on December 12th. Other users will be able to walk you through your difficulties and hopefully put you back on the right track. Blackadder 23:43, 27 November 2006 (UTC)
If you'd like to contact me via email (details on my user page) I'll try and help. Would help to know if you are using it on Windows etc, and any specific problems you may have. Dmgroom 23:51, 27 November 2006 (UTC)

I am new on OpenStreet. I also find it difficult to get JOSM working. It starts with the loading, using a BAT file!?! Then the woeking with maps, is anyones guesswork. I have been able to download the Landsat plugin, also the button is showing up in JOSM. But I can not get the program running to get the Landsat overlay. So yes, I think someone should elaborate the description of JOSM. Thinking about newcomers. Maybe I have problem because I am using Windows XP Home, soon Vista.--Af Gultarp 15:38, 22 January 2007 (UTC)

JOSM's own site might help -, expecially the help section. I don't see why Windows would make anything more difficult, I used to use it for OpenStreetMap. Bruce89 18:01, 22 January 2007 (UTC)
The ability to download a Landsat data overlay is only available if you have already loaded either OpenStreetMap data, or Raw GPS data for a particular area. Therefore you will need to first either download that data from the OSM server, or load a GPX file from your own hard disk. The online help referred to above by Bruce89 does not contain a basic introduction to JOSM. I'll try and write one. Dmgroom 00:16, 23 January 2007 (UTC)
I've added a basic introduction to JOSM at Help Introduction. Dmgroom 00:45, 23 January 2007 (UTC)
Thanks for writing this. Bruce89 13:04, 23 January 2007 (UTC)
We have a newbie-friendly editor on the way which will ease your path into using JOSM. You'll be able to use this to get started, then move to JOSM when you're a bit more confident with OpenStreetMap. --Richard 09:47, 23 January 2007 (UTC)

WMS plugin in JOSM not working

I upgraded the JOSM client after the protocol change. Since then, the JOSM wmsplugin is not working anymore. If I download the ways of a certain area and try to download the Landsat images for the background, the ways turn gray and cannot be changed, or new ways added. Is this problem known? When will it work again? Are there any fixes? Thanks, Longbow4u 13:37, 8 October 2007 (BST)

Delete the plugins in the plugin directory, and re-download via preferences box, it should work after that ...--PhilippeP 14:08, 8 October 2007 (BST)
I am running Windows Vista and have this problem too. The WMS layer seems to sit on top off everything else. If I add a new node it disappears behind the Landsat image.--Mister B 18:28, 20 October 2007 (BST)
I could solve the problem in the meantime. You have to go to the Edit tab in JOSM, there on Preferences and uncheck the box Draw inactive layers in other color. After downloading the WMS Landsat tiles of your area, just click once on the "Create a new map" button in JOSM on the top, and it will work as before. Longbow4u 18:49, 20 October 2007 (BST)

Web Start?

How about using Java Web Start for JOSM? I have a demo here: (See also Talk:Yahoo! Aerial Imagery#Yahoo! images for "Web Start" JOSM?) --Raf 22:08, 5 March 2007 (UTC)

Using osmarender plugin

When clicking on the menuitem view -> osmarender, JOSM reports it cannot find Firefox and suggests that the path to the executable is set in the preferences. Assuming a new setting should be created in Edit -> Preferences -> Advances preferences, which keyname is to be used? --Lambertus 12:46, 12 March 2007 (UTC)

I just encounterd this message in the mailing list. It suggests adding the following new setting to the Advanced preferences: "osmarender.firefox". The value should contain the path to the Firefox executable. --Lambertus 12:46, 12 March 2007 (UTC)

On MacOSX, the path to the executable is: /Applications/ --Chupacerveza 2 May 2007

Run JOSM from flash drive with your prefs - HOWTO added

A HOWTO has been added to solve this issue. --LeedsTracker 14:23, 24 September 2007 (BST)

Java is not installed on some company or university Windows boxes, but you can copy the Java runtimes from another installation onto a USB flash disk and run it from there. I can run java -jar josm.jar from this portable installation but the preferences are saved to "%APPDATA%/JOSM" which is on the system hard disk, rather than my flash drive.

Can anyone tell me how to run this so the prefs are loaded and saved to my flash disk? --LeedsTracker 11:58, 14 September 2007 (BST)

Nice catch! Java picks up the APPDATA environment variable (on windows), which you can change prior to launching java to whatever you wish via simple command set APPDATA=g:\josm\appdata Batch file should look something like
set APPDATA=g:\josm\appdata
g:\java\bin\java.exe -jar g:\josm\josm-latest.jar
Assuming G: is your usb drive (but can probably made even more flexible). Good luck, --Stefanb 14:05, 14 September 2007 (BST)
Thanks for the quick response Stefanb, that did the trick - should have thought of that myself. Prefs are saved in %appdata%\josm\preferences (where preferences is a file), so in your example above, if I set %appdata% to g: it saves prefs to g:\josm\preferences which is fine.
You can omit the drive letter by using relative paths, e.g.
set APPDATA=\somefolder
\java\bin\java.exe -jar \josm\josm-latest.jar
That way, it doesn't matter what drive letter my flash drive is assigned.
JOSM then runs OK but I get an error popup at startup:
Error initializing test SpellCheck
...and in the DOS box on launch it says:
java.lang.NoClassDefFoundError: org/openstreetmap/josm/gui/preferences/AnnotationPresetPreference
If I can work this one out I'll do a little HOWTO. Thanks again! --LeedsTracker 15:56, 14 September 2007 (BST)

412 precondition failed

I created a ticket on JOSM dev page for this. I saw other tickets with the similar bug report:

I'm using the latest jar file (as of 08th October 2007). When I try to upload the changes, JOSM uploads updated and modified objects, but when it starts to send info to server about deleted objects I get the following message box: Error while parsing: An error occured: 412 precondition failed. This happens every time I try to upload the info about the deleted objects.--Breki 19:25, 8 October 2007 (BST)

My guess is, that you are trying to delete nodes on the edge (or even outside) of your OSM data bounding box. Deletion of the node might succeed locally if you delete the way first, but if the node is also used by some other, not downloaded way the precondition "node must not be used by any way before it can be deleted" fails on the server. Try downloading a bigger area to get the wrongfully deleted nodes back and re-do your upload. --Stefanb 09:33, 9 October 2007 (BST)
Even if this is true, this was not happening in the previous (API 0.4) versions of JOSM. And I also loaded a much bigger area, so it is not overlapping. I tried this again with the latest version (JOSM v368) and it is still happening. If I save the data to file, then restart the JOSM, load that file back into JOSM and try to upload the changes, the same error occurs. I can send the example of this file to anybody who's interested. --Breki 17:07, 12 October 2007 (BST)
As a workaround, you can open the OSM file with a text editor and remove the "action" attribute of the element in question. --Colin Marquardt 17:17, 12 October 2007 (BST)
Thanx for the info. The problem is that this doesn't really help me, because I'm trying to update areas which mistakenly had shared segments in the 0.4 database and have now been converted into several separate ways sharing the same relation (multipolygon). I have to combine those ways into a single area and upload that to the OSM server and that's when this error occurs. I suspect it has something to do with relations feature, since I also saw other bugs reported by JOSM related to relations editing. BTW I posted a bug report to the newly created JOSM dev mailing list.--Breki 18:54, 12 October 2007 (BST)

400 error in attempting to download data

Hope this is the correct place to put this. Whenever I attempt to download any data into JOSM (latest version), OSM or GPS tracklogs, I get the following error message:

"Server returned HTTP response code: 400 for URL: (URI continues)"

I am positive my email and password are set correctly to my OSM login (not my wiki login). Reasons/suggestions anyone? Thanks -Iainfs 15:07, 10 April 2007 (BST)

This is usually because you are trying to download too large an area. The OSM API only allows areas smaller than 0.3°x0.3°, try and break your download into smaller areas. Bruce89 15:25, 10 April 2007 (BST)
I repasted the URI from the online map page and all is working great now :) Thanks for your help -Iainfs 21:57, 10 April 2007 (BST)

Plugin directory in Windows Vista

I don't know where to put the plugins in Windows Vista.

As long as "Documents and Settings" doesn't exist, I tried to put them in several locations but it didn't work, including:


C:\Users\username\Application Data\JOSM\plugins


Has anyone installed JOSM with plugins in Windows Vista?

-- User:Nosolomusic 11:28, 4 June 2007


Could do with more detail on how to use presets. I had them working, but when I upgraded JOSM they stopped working. Someone suggested that the default location had been changed, but I have an explicit path in my settings. Steevc 12:40, 30 August 2007 (BST)

Looks like
...was renamed
This is the URL shown in the image on the Tagging Presents page. Is that the one you were pointing at?
Looks like there's some bigger files checked in here: but only updated 1 year ago. Isn't there a presets file kept roughly in synch with Map Features page?
-- Harry Wood 00:32, 14 September 2007 (BST)

I'm using JOSM in German. When defining presets, JOSM translates some of the english values (e.g. "gravel" becomes "Schotter") to german, but not all. Some translations do not make any sense at all (e.g. the value "track" for the key "highway" is translated to "GPS-Track"). How can I prevent the automatic translation? --Kaivi 17:42, 30 May 2009 (UTC)

Exception when invoking josm from command line

I am experiencing problems when I invoke josm from the command line. I use Kubuntu Hardy Heron and installed josm from the repository.

Using /usr/bin/gij-4.1 to execute josm.
Exception in thread "main" java.awt.AWTError: Cannot load AWT toolkit:
   at java.awt.Toolkit.getDefaultToolkit(
   at javax.swing.plaf.basic.BasicLookAndFeel.initialize(
   at javax.swing.UIManager.setLookAndFeel(
   at javax.swing.UIManager.<clinit>(
   at java.lang.Class.initializeClass(
   at javax.swing.UIManager.getUI(
   at javax.swing.JLabel.updateUI(
   at javax.swing.JLabel.<init>(
   at javax.swing.JLabel.<init>(
   at javax.swing.DefaultListCellRenderer.<init>(
   at javax.swing.JList.init(
   at javax.swing.JList.<init>(
   at org.openstreetmap.josm.gui.preferences.ToolbarPreferences.<init>(
   at org.openstreetmap.josm.Main.<clinit>(
   at java.lang.Class.initializeClass(
   at java.lang.Class.initializeClass(
Caused by: java.lang.UnsatisfiedLinkError: libgtkpeer: cannot open shared object file: No such file or directory
   at java.lang.Runtime._load(
   at java.lang.Runtime.loadLibrary(
   at java.lang.System.loadLibrary(
   at java.lang.Class.initializeClass(
   at java.lang.Class.forName(
   at java.awt.Toolkit.getDefaultToolkit(
   ...15 more

I installed the libgtk-java package after receiving this message, but to no avail. --Ipofanes 06:15, 23 July 2008 (UTC)

Update: I have found a workaround: When I install the Sun version of Java, JOSM starts. The downside is that I have to sign a most shackling license to do that. Ipofanes 04:19, 31 July 2008 (UTC)==

JOSM 1529 and protocol 0.6

I have made a lot of OSM changes before the protocol 0.6 upgrade. Since the protocol upgrade to 0.6, I haven't been able to upload changes to OSM. I tried with JOSM version 1515 (that I had before) and with the latest (version 1529). I know that I've got the correct username/password because when I specifically enter incorrect data, it will ask for this username/password again. I've also provided the requested comment for the update.

I have specifically downloaded a small region (that I recently GPS surveyed) and deleted one road (that doesn't really exist) just to test the upload. It is a deletion of a way and sixteen nodes. I get an error, "Transfer aborted due to error (will wait for 5 seconds)". I have no proxy server between me and the Internet, so I don't have to worry about the proxy settings. I am using Ubuntu 8.04. (I haven't upgraded to a later version yet because of a software incompatibility that I hope has been fixed in 9.04, but I haven't been able to test yet.)

I tried the upload help, but there was no help there. I've also looked other places with no help. I don't know where else to look for help. It is probably something simple, but I have no idea what to do. — Val42k 04:31, 24 April 2009 (UTC)

I tried various things that didn't work. I finally tried the latest JOSM version (1555), downloaded the data with this version, made changes and uploaded them. It works now. — Val42k 23:25, 25 April 2009 (UTC)

Lot of problems using the (almost) latest version

I used to use JOSM and liked it, but unfortunately a few weeks ago I updated on Version 1515 and editing is now near horror. Some stuff I've got quite a lot of problems with:

  • Normally, when I start I open a gpx-File (from 60CSx). This worked great until lately. Now after loading the file nothing is shown. I first have to go to the layer-dialog and convert the layer to gpx which sounds strange, because it is allready gpx. Unfortunatly this layer is two layers (I never understood why) and I have to find out which to convert, which is quite nerving.
  • Next I upload an other gpx-File with the waypoints. This works fine.
  • Next I download data from the server and the data from the first gpx-File disappers again. I have to move some layers up and down until it shows up again. I still have not understood how to arrange the layers.
  • This whole procedure used to be about 5 clicks and takes now about 5 minutes (not including the download itself).
  • Next I've got problems with thay layer-dialog. Its to small, it shows only 3 layers and I've got to scroll it up and down... I didn't find out, how to get it larger.
  • I'm used to have the layer dialog at the top, but now it displays at the bottom. I'd prefer to have it back at top. (This is of course not a severe thing, but it adds to me disliking using the current version.)
  • Now I try to edit stuff. This works quite well, but from time to time josm starts a new way. I think I could track this down to my mouse doing doubleclicks sometimes. I don't care, because I've got no other application found, where this is a problem. Unfortunately I didn't find a way to remove this (for me annoying) double-click-feature. I went though the Einstein-Dialog but I didn't find anything.

For the moment I can use an old version, but I guess, that with the change to API 0.6 I'll have to use the new one...--Kumakyoo 14:35, 14 April 2009 (UTC)

Using the current -latest version, 1526, I can't confirm any of your problems except for the ugly behaviour of the dialogs on the right. I opened a gpx-file from my Garmin Vista, loaded a separate file with some waypoints, downloaded data and everything works fine. The layers' order is like this: track(gpx), osm-data, waypoints(gpx), waypoints imported from that gpx, gps-data from the server and the osm-data layer is selected and active.
You may be right with the layer dialog, it should be easily resizeable, but there is a simple workaround: just minimize many or all of the other dialogs in the sidebar - then it gets bigger and stays big when you get the other dialogs back in full size.
I can also confirm that it is impossible to move all those dialogs. Imho, this should be possible. But for that problem there is also a workaround: detach and reattach the other dialogs one after the other (by clicking the pin symbol and closing the little window again) and they will appear at the bottom, shifting the layers dialog up again. --Cobra 17:12, 15 April 2009 (UTC)
  • I can confirm problems with versions 1523, 1526 and 1527. Most times the upload takes a long time (longer than usual) and will often abort with an error (*) and is generally very unstable. Sometimes download takes a long time too. Something about the connection to the server seems to have changed in a bad way. So I'm back to 1488 - this version works great. HdEATH 13:06, 16 April 2009 (UTC) [* When uploading changes I get: Übertragung wegen eines Fehlers abgebrochen (Wiederholung in 5 Sekunden) Server returned HTTP response code: 400 for URL: This error never occured in versions < ca1500]


Is there a chance for I18N support in JOSM? Or is there a good way of translating the menues and the help to other languages? If needed I can help with creating I18N language files for Norwegian and Portuguese if I have something to work out from I know many Brazilian users want to see more tools with Portuguese language support.... --Skippern 03:42, 17 September 2008 (UTC)

Looks like translations of the JOSM menus etc are being coordinated here: Don't know much about it myself. Looks like User:Stoecker would be the man to ask. -- Harry Wood 11:54, 9 February 2009 (UTC)

Splash screen = start button

Maybe this is worth a bug report (usability): I had nearly given up using josm, because the spash screen seemed to freeze. Only a student of mine found out, that you have to click on the splash screen in order to make josm start!

Next hint: use key "U" in order to stop adding nodes to a linear object (street).

Can I extend the set of pre-defined attributes/values (quite thin pre-selection)?

-- User:RalfG 18:14, 23 September 2008

Never seen that. The splash screen doesn't require a click. Maybe when they first introduced the splash screen it had that behaviour. Are you still seeing this with josm-latest ? which OS & java version? -- Harry Wood 12:07, 9 February 2009 (UTC)


While downloading an area I want to work I sometimes get a message "There where conflicts in the downloaded area" but nothing comes up in the conflict list. This also blocks me from uploading, as I get an "There are unresolved conflicts" message. That means I have to delete the entire map and download everything again. Is there any work around this problem? Using latest version (build 1096), from work on an WinXP computer. --Skippern 21:27, 30 November 2008 (UTC)

Make sure you don't edit outside of the area you have downloaded in order to reduce this problem.
Resolve conflicts by opening the 'conflicts' panel, selecting the one of the listed conflicts and choosing whether to accept 'theirs' or 'mine'. This should probably be documented the 'Conflict dialog' JOSM help section. Maybe I'll paste this text in as a start.
-- Harry Wood 11:59, 9 February 2009 (UTC)
The problem seems to be solved now as I havn't seen this on later versions of JOSM, the problem I had was that there was no conflicts listed in the conflicts panel. --Skippern 15:12, 9 February 2009 (UTC)

Selecting ways using the same nodes

If I want to select, for example, a road that is also used as the edge of a park, how do I select the road? The page says:

to select different ways which use the same nodes, then middle click the way then hold ctrl and left click the way you want

...but this does nothing for me. I have no middle-click, just left and right. Ctrl and Left click just selects the park. I don't want to unglue things unnecessarily. --LeedsTracker 02:44, 22 January 2009 (UTC)

Playground/sandbox version

I would like a test installation of JOSM that uses a dummy dataset. Users wanting to get used to the editor could feel freer to mess around with it without worrying about messing up the real OSM data. This sandbox/playground idea definitely helped me gain confidence in using wikis like Wikipedia.

I suppose this idea requires an OSM server with a dummy dataset that could be uesd by playground installations of Potlatch and JOSM. It could be based on a small 'island' with a few existing features. --LeedsTracker 20:18, 12 September 2007 (BST)

To some extent this is easy to do, Just do not enter any user information and it can't upload to OSM. Download still works and they can edit to their hearts content. Even saving their changes to a file. Perhaps a note about doing this for new users would make them more comfortable and help get people started. --Dalep 22:17, 5 May 2009 (UTC)

Tool to move features in separate layer

Sometimes, the woods and forest are disturbing when editing maps. Maybe it would be a nice addon, if it'd be possible to move "areas" (or other features maybe based on a selection) in a special layer, to protect them (or also the other layers, like highway) when editing...

Woods and forests etc. became much easier to handle with the transparency feature in the mappaint plugin, but moving certain things to a different layer would be useful for the Tiger fixup. --Colin Marquardt 14:27, 27 November 2007 (UTC)
The mappaint plugin was removed, is there a replacement? --UncleOwen 11:27, 28 May 2009 (UTC) looks like it's included by default now --UncleOwen 11:28, 28 May 2009 (UTC)

I agree something like a special hidden layer. Still part of the main layer for upload reasons, but with the ability to turn visibility on/off and or make it grayed out and unselectable. Along with this, a better copy/move to layer that retains it's original location (unlike copy/paste) and id's. Just a new/alternate paste that retains the original location would be nice. This may create some new data management issues if used heavily (diff/merge?), but could be very useful. --Dalep 22:40, 5 May 2009 (UTC)


I'm new here, but I wanted to note that I was able to run JOSM and do everything I tried (which isn't everything) with IcedTea. IcedTea is a GPL-licensed combination of Sun's OpenJDK and GNU Classpath. Mattflaschen 04:49, 1 February 2008 (UTC)

I regularly check that it compiles and starts under icedtea, AFAIK the only thing that does not work is the slippy map chooser plugin. If you've got any other problems with JOSM under icedtea, don't hesitate to contact me. --GabrielEbner 11:46, 1 February 2008 (UTC)
Since it mostly works, wouldn’t promoting it instead of Java SE be better, since this is OpenStreetMap? Fophillips 12:06, 31 May 2008 (UTC)

Polygons and Properties

I'm trying to create a woodland type map which will require lots of different polygons e.g. Museum building outline, country house building outline, garden, conifer trees, broadleaf trees etc

I have created closed ways for some of these features but don't know what properties will create a polygon. E.g. I created a school playground polygon and called it Amenity: school. This created a nice polygon but I have tried other Presets on JOSM but most refer to point features e.g. Museum. So how do I know which Preset Properties are for polygons and which are for points?

Note the closed ways which I could not label appeared only in MapLint.

I intend to use a local version of osmarenderer so don't really care about formatting as long as a closed way gets through to the OSM data file as a polygon.


User:Parthian 16:43, 14 February 2008

Render plugin which produces a rendered preview as a new layer

I just installed the Osmarender plugin which enables firefox to display the area you see in JOSM but I'm not quiet content with it:

  1. The data seems to be rendered everytime the browser needs to update the view which is very cpu consuming and it is a pain to use it on slower machines.
  2. The rendered data is not exactly the selected area but seems to be a bigger area.
  3. The size of the displayed items appear very thin and the text is very small. I don't know how to change it.
  4. Having an overlay which is a separate layer in JOSM like the WMS plugin produces would be more helpful as you can also use it for finding nodes which may be aligned incorrectly.

Does anybody know if someone is working on a plugin which empowers JOSM to display a preview which corresponds to the view like you see it on It would be great if you can select Mapnik as the default renderer for the preview in JOSM as this renderer seems to be the one which is used by default for displaying the slippy map on Like the WMS plugin does the data should only be rendered on demand (like you hit the update button and you get a new rendered overlay).

What do you think?
--Sternenfaenger77 11:41, 23 February 2008 (UTC)

Does JOSM run under IBM Java? If so, I could at least run it on my iBook whose OS X 10.3 only runs Java 1.4. Ipofanes 15:18, 15 December 2008 (UTC)
You need at least Java 1.5 --Skippern 15:20, 15 December 2008 (UTC)
So IBM Java is fine, as long as it's 1.5? See above how GNU Classpath fails despite supporting Java 1.5. Ipofanes 16:52, 17 December 2008 (UTC)
I don't know IBM Java, but the JOSM requirement is Java 1.5, that means Sun Java 1.5 or equivalent, and all the java systems I have seen uses a similar versioning structure. If IBM Java 1.4 have the similar command structure and class building properties as Sun Java 1.5, than that is good enough, if not, than you need to choose a different system/version. Blackdown Java and OpenJava are also other alternatives to Sun Java and IBM Java. --Skippern 17:05, 17 December 2008 (UTC)

Using JOSM behind a Proxy which requires user authentication

Right now i'm working in a LAN where the access to the external network is managed by a Proxy with UserID/Password authentication. Does anyone know how to pass these parameters to JOSM? --Danilo 10:49, 2 April 2008 (BST)

I also tried to run JOSM passing this parameters from the console but nothing:
java.exe -Dhttp.proxyHost=USERNAME:PASSWORD@PROXY_ADDRESS.IT -Dhttp.proxyPort=8080 -jar d:\Programmi\josm-latest.jar --Danilo 18:34, 2 April 2008 (BST)

It seems the information about the proxy in the wiki page is out of date (is not used by josm). Configuration via JOSM does work. In the German version the checkbox is titled with "anoymous" but for anonymous this box has to be unchecked.--plaicy 21:12, 18 September 2008 (UTC)

If you can get JOSM to run with a proxy at all, then the easiest way is to install a local HTTP proxy and let that take care of the authentification. There is plenty of free proxies out there, I successfully used the ad filter Webwasher 3.4 to get past a company firewall. --Nop 07:44, 6 November 2008 (UTC)

Landuse Filter

Is there in JOSM some filter. I am editing routes between small forests. Sometimes would by very useful, if there will be option how to hide something.. For example all ways with Landuse tag.. Drawing new points, and moving this map will be to much faster. Here is example for this area: Middle Slovakia - Freemap

We chatted about a "landuse layer" idea down the pub. Would be nice if editors became more intelligent about landuse areas hey? Probably a fairly big change with implications for general data handling. Imagine JOSM users start uploading landuse areas which butt up against each other perfectly. Now imagine area an border along the line of a road. What will potlatch users see? Unless potlatch gains such features in parallel... it'll be rather an uneditable mess.
So it's a bit tricky, but certainly a future area for enhancement -- Harry Wood 12:15, 9 February 2009 (UTC)

JOSM Plugin for windows instructions

I'm having a hard time getting the plugins to work, the instructions that are on here are rather vague. When in JOSM, it automatically downloads the files it needs. But i cant find those files that were downloaded. Do i have to have JOSM in the same directory ad these plugins? Why can't I change the directory that they get downloaded too? For step 2, do i have to create that directory? --acrosscanadatrails 08:07, 24 January 2009 (UTC)

No it's all automatic. In windows the plugins get downloaded to: C:\Documents and Settings\your name\Application Data\JOSM\plugins You dont need to create that directory. You don't need to have JOSM jar in any particular directory. It should work anywhere. You could create a folder C:\Program files\JOSM\ for example. -- Harry Wood 12:25, 9 February 2009 (UTC)

Base Server URL: (replace with other?)


can I change the Base Server URL to some other one? I've read there is a read only server with only 10 minutes in delay, that can give larger quantities of data. I've tried changing it once to but I'm not sure if that was a good thing to do. Logictheo 13:44, 18 June 2009 (UTC)