Zh-hant:JOSM

From OpenStreetMap Wiki
Jump to: navigation, search
可用的語言 — JOSM
· Afrikaans · Alemannisch · aragonés · asturianu · azərbaycanca · Bahasa Indonesia · Bahasa Melayu · Bân-lâm-gú · Basa Jawa · Basa Sunda · Baso Minangkabau · bosanski · brezhoneg · català · čeština · corsu · dansk · Deutsch · eesti · English · español · Esperanto · estremeñu · euskara · français · Frysk · Gaeilge · Gàidhlig · galego · Hausa · hrvatski · Igbo · interlingua · Interlingue · isiXhosa · isiZulu · íslenska · italiano · Kiswahili · Kreyòl ayisyen · kréyòl gwadloupéyen · Kurdî · latviešu · Lëtzebuergesch · lietuvių · magyar · Malagasy · Malti · Nederlands · Nedersaksies · norsk bokmål · norsk nynorsk · occitan · Oromoo · oʻzbekcha/ўзбекча · Plattdüütsch · polski · português · română · shqip · slovenčina · slovenščina · Soomaaliga · suomi · svenska · Tagalog · Tiếng Việt · Türkçe · Vahcuengh · vèneto · Wolof · Yorùbá · Zazaki · српски / srpski · беларуская · български · қазақша · македонски · монгол · русский · тоҷикӣ · українська · Ελληνικά · Հայերեն · ქართული · नेपाली · मराठी · हिन्दी · भोजपुरी · অসমীয়া · বাংলা · ਪੰਜਾਬੀ · ગુજરાતી · ଓଡ଼ିଆ · தமிழ் · తెలుగు · ಕನ್ನಡ · മലയാളം · සිංහල · བོད་ཡིག · ไทย · မြန်မာဘာသာ · ລາວ · ភាសាខ្មែរ · ⵜⴰⵎⴰⵣⵉⵖⵜ ⵜⴰⵏⴰⵡⴰⵢⵜ‎ · አማርኛ · 한국어 · 日本語 · 中文(简体)‎ · 中文(繁體)‎ · 吴语 · 粵語 · ייִדיש · עברית · اردو · العربية · پښتو · سنڌي · فارسی · ދިވެހިބަސް
JOSM Screenshot, showing the geo-tagged images feature.
JOSM Screenshot with (outdated) landsat.jar and mappaint.jar plugin.


JOSM的全名是"Java OpenStreetMap Editor"是一個桌面程式由Immanuel Scholz開發,目前的維護者是Dirk Stöcker。官方網站為這裡

雖然它需要一些學習的時間,JOSM依然因它的插件廣泛性和穩定性,而令到成為人氣的OSM繪畫程式

選擇哪個編輯器

OpenStreetMap可以使用不同的編輯器來編輯,例如:線上編輯器PotlatchMerkaartor。那麼何時該使用JOSM,何時又該選擇其他的編輯器呢? 那,由於JOSM有不同的插件支援,所以它需要一些安裝和設定來令到電腦能夠接上,而且JOSM有不同的功能,所以需要一些時間習慣,但習慣了後就能使用不同的插件並在OSM上繪畫了!

當發生以下的狀況,JOSM可能不適合你的需求:

  • 只是希望命名一條道路。這種情形,你應該考慮在線繪畫
  • 你不希望在電腦上安裝應用程式。
  • 你在防火牆不允許你使用JOSM的地方編輯。(例如你工作的地方)
  • 你的電腦不符合下面所列的基本需求。

如果遇到以下狀況,你應該使用這個離線編輯器:

  • 你打算修改大量的資料。
  • 你想修改資料但是不會有立即的影響。(做些實驗)
  • 你希望張貼你沿路拍攝的相片。
  • 你打算使用離線編輯器,而且認為同時有其他人正在修改同樣的地區。JOSM支援合併不同的修改,且解決衝突的問題。(但還是請記得在每次上傳之前先下載線上的最新版本)

系統需求

為了執行 JOSM,你的電腦需要有:

  • 建議使用Java 8或更高版本
    •  如果沒有可以下載
    • (舊有的Java版本或能在部份JOSM中使用,詳情請見JOSM的系統需求
  • 512 MB 或更多的記憶體
  • 1024x768 或更高的解析度 (使用低解析度會令到介面難以操作)
  • 使用顯示卡可以增加流暢度

下載及安裝

JOSM程式可以在JOSM官方網站下載。

如果不幸連接不上官網,可以到以下地方下載: Github JFrog Bintray(只限測試版,不建議新手使用)

啟動

正常在完成安裝Java情況下,您只需雙按JOSM.jar就能啟動,如果未能成功啟動,請見如何啟動Java應用程式

JOSM在處理大量數據下可能需用大量的記憶體,如您覺得需要使用更多記憶體,可使用如何啟動Java應用程式中命令終端後加上-Xmx1024m,其中1024是指JOSM可以使用多少MB的記憶體。

使用-Dsun.java2d.opengl=true選擇使用顯示卡也是一個增加JOSM流暢度的方法。

升級

JOSM會自動檢查升級及在啟動介面中顯示升級內容。人手確定最新版本可到官方網站

開始繪畫地圖

下載地圖資料

簡單來說按(JOSM-Icon Daten download.jpg)→ 選擇繪畫區域 → 按「下載」啦

在開始繪畫地圖前,您需要先下載地圖資料(就算不需要衛星地圖,也需要其他人在OSM上已繪畫的資料!) 先按下「下載」按鈕(JOSM-Icon Daten download.jpg)來打開下載介面。

最初會開出一個地圖介面,您需要在這裡選擇所繪畫的區域來下載,注意左鍵可不是移動!右鍵才是移動地圖,而左鍵是選擇。

注意避免一次下載過多的地圖區域(因為OSM伺服器需要時間回傳資料,而且JOSM不能處理過多資料),建議您只需下載一個住宅區域,在之後還可以下載更多的地圖區域。

選擇了區域後還需要按下「下載」按鈕(Download)才會開始下載。

繪畫節點

JOSM Keyboard Shortcuts Cheat Sheet A3 300 DPI影印版本

在JOSM中,最常用的工具為:

S鍵:Objekte auswaehlen.png(Selection) 選擇工具

A鍵:Setze Knotenpunkt.png(Selection) 增加節點

完整的快捷鍵列表可以在這裡參考到。

  • 這裡有一些有用的教學影片 [1]
  • If you have a GPX tracklog file of the ways you want to map, start JOSM. Choose File → Open to select and load your track. JOSM will automatically fit the workspace to the bounding box of your track.
  • If you don't have a GPX tracklog file then you may want to use data collected from other users. See Korea Mapping Guide
  • If you want to play around while learning how to use JOSM without changing the data on the server then just don't upload (downloading is OK), delete the layers you changed, and then start over.
  • 永遠在編輯之前先下載資料。即使你在使用儲存在自己電腦的資料也是一樣。
  • To exchange data with the server ensure you have entered your username and passphrase in the preferences of JOSM. Your username is not your wiki username but the email address you used for registering.
  • Now choose File → Download from OSM. In the following dialog ensure that the checkbox to get OSM data is enabled and press the OK button. Always download before uploading.
  • If the track is too long, the server will refuse to send you the OSM data for that area. Zoom in a bit to restrict the request to a reasonable size.
  • Wait a bit until all the data has been received. If there are existing ways of your area in the database, you will now see them in JOSM.
  • Now start your editing session. Be careful when changing existing data, as streets and nodes can have lots of tags assigned.
  • The JOSM manual is available online here, and these pages can also be accessed by pressing F1 from within JOSM. If you really mess things up simply delete the layers that have been changed before you do an upload and then start over.
  • See here for a list of default shortcuts.

提示和小技巧

See also JOSM/Advanced Tricks (more tips for more experienced users)

  • 在安裝外掛之後,你必須去 preferences 啟動或關閉這些外掛。
  • For users new to OSM, it is recommended to use a presets file for easier tagging. Ask for one in the mailing list or User:SlowRider
  • If you do not have a wheelmouse, you can zoom in and out using the key combo Ctrl-. (period) and Ctrl-, (comma).
  • If you mapped one lane of a motorway, find here a tool which creates the opposite lane for you.
  • The node dragging sensitivity is set quite low. You will probably find that setting the threshold to 5 will make it more sensitive. In Advanced Preferences add a key named edit.initial-move-threshold and give it a value of 5.

Automatically Matching Photos to GPS traces

One of the problems when out mapping with a GPS is trying to keep accurate notes about the street names as you pass each junction. If you have a digital camera to take out with you, JOSM can help.

  • take a photo of your GPS screen/display showing the time (on the GPS) when you start

As you are travelling around, take a picture at appropriate places/junctions/road signs. Then, when you get home with your completed GPS track uploaded into JOSM:

  • In the "Layers" box, top right
  • Right click on the GPS track layer, for the layer you have just uploaded. Note: you must do it from a layer you have just uploaded, and not from data that was downloaded from OSM, as that apparently no longer has a timestamp.
  • Select "Import Images" (or possibly "import photos")
  • Right click the photos layer,
  • Sync the clocks using the (camera's timestamp on the) photo you took at the start (of the GPS screen/display clock)
    • If you do not have a picture of the GPS for some reason, turn on the camera and GPS now. Work out the time difference between them. Now, subtract or add this to the time shown in the 'sync clocks' photo dialog.

The "Geotagged photos" feature is built in to JOSM. However you might like to try out the AgPifoJ plugin which works in a similar way, but offers enhanced reliability and usability.

For more information see Photo Mapping

Automatically Matching Sound Recordings to GPS traces

There is now a similar facility for applying and synchronizing sound recordings.

There are three methods, described with step-by-step instructions, in the JOSM Help:

1. Continuous audio with GPS waymarks

With this method, you collect explicit waypoints along your track using the buttons on your GPS and at the same time dictate onto a continuous sound recording on your voice recorder what the waymark represents on the ground - a street name or point of interest. Your GPS notes three key pieces of information about each waypoint - its location, the time it was made, and it's name or number. The audio and waypoint data are then synchronized in JOSM so that you can play back each description by clicking on a Marker representing the waypoint.

2. Continuous audio with vocally-identified points of interest

With this method you also make a continuous sound recording but instead of entering waypoints into your GPS you dictate an audible cue for each point of interest, for example "MARK! River Lane Primary School on left".

3. Audio clips with waymarks

With this method, you make waypoints to identify locations of interest. However you record a separate audio file for each one and the name of each file is added as a <link> element in the corresponding waypoint in the GPX file before loading into JOSM. When JOSM then creates the Audio Marker for each waypoint, it knows which audio clip to play when you click on the marker.

For more information see Audio mapping

Newbie Notes

Here's a few notes from a beginner's (Parsingphase) first couple of days working on OSM, using the JOSM editor (on Mac OS X).

Mac-specific points

  • "Installing" JOSM on OS X is a cinch — just download and double-click the .jar file.
  • Use a two-button mouse with a scroll wheel — it makes life much easier. Right-dragging moves the map, the scrollwheel zooms.
  • Otherwise, command-click (aka "Apple-click") does a right click, ctrl-arrows to move the map, and ctrl-, and ctrl-. to zoom.
  • Because it starts with a dot, your ~/.josm directory will be invisible to the Finder. You either have to move the plugins into it from the command line, or open the folder using "Go to Folder..." ("Go" menu in the Finder).
  • There's a Mac OS X look and feel under the Edit → Preferences menu; it doesn't actually change any functionality but it fits in ;)

Points for all platforms

  • to select different ways which use the same nodes, then middle click the way then hold ctrl and left click the way you want
  • Get the "mappaint" rendering mode. It makes it far easier to see what's going on in your maps (and even work out where on earth you are), at the expense of slightly higher processor load on your machine (my PowerBook 12" copes fine). (This plugin has now been integrated into JOSM and can be turned on and off from the View menu > Wireframe view.)
  • Upload and download small areas, frequently. The less time you've got unstored or unchecked changes, the lower the risk of conflict with other users.
  • Always download an area before you start work on it, even if you have your own GPX data.
  • Always download the area you are going to upload before doing so, to get any modifications made by other users and avoid overwriting data.
  • When downloading an area you get all the data within the rectangular bounding box you choose, and also, where any way within that bounding box extends outside the box it is completely downloaded. It therefore becomes difficult to precisely know which areas you have downloaded full data for. If you check the "Draw boundaries of downloaded data" box (found in Edit > Preferences > Display Settings), a yellow rectangle is drawn around all the areas for which full data has been downloaded. Caution should be exercised when adding new data to areas outside these rectangles as it may duplicate already existing data, which you have not downloaded.
  • A "small area" to start with might either be that from a short GPX track you've taken, or about a 1-km square around a known location. This equates to about 0.06° of latitude/longitude (give or take polar distortion), so enter an area about that size into the File → Download from OSM → Bounding Box.
  • Rural areas with less detail might work better with larger areas — the 1-km recommendation is about right for a suburb of London.
  • Once you're viewing an area in JOSM, at whatever zoom level, the JOSM download dialog box will default to the currently viewed area.
  • It's very easy to select more than you expect to, particularly when making "ways". Open the "Current Selection" panel (Alt-e, fifth button up on the left) to keep an eye on what you've selected.
  • Switch back to "select" mode regularly and click on nothing or type Ctrl-Shift-A to clear your select list.

Why don't my changes appear?

  • See Map Features for how to specify that your way is a road/railway etc, and what type. If you're not sure of the type (e.g. primary/secondary) be conservative and choose the lesser (e.g. secondary).
  • The slippy maps may not contain your changes immediately - see FAQ entry

See also

Related

External links